GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » General » FairSoft Installation failed on CentOS7
Re: FairSoft Installation failed on CentOS7 [message #25662 is a reply to message #25655] Wed, 09 June 2021 08:43 Go to previous messageGo to previous message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *hsi16.unitymediagroup.de
Hi,

if you are using the default compiler on CentOS 7 you will not be able to install FairSoft nov20 since this version needs at least C++14 which isn't supported by gcc 4.8.5.

Redhat provides so called developer toolsets which allow to use newer software packages. Please check if you can use the devtoolset-7 which includes gcc 7.3.1 which is able to compile FairSoft nov20. You enable the toolset with the following command.

> source scl_source enable devtoolset-7
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: PandaRoot Oct19 failed to install
Next Topic: PandaRoot test failed on CentOS7
Goto Forum:
  


Current Time: Mon Jun 17 05:42:02 CEST 2024

Total time taken to generate the page: 0.01093 seconds