GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Monte Carlo Engines » gphysi.dat (gphysi.dat Output with GEANT4)
Re: gphysi.dat [message #22777 is a reply to message #22776] Mon, 09 July 2018 14:47 Go to previous messageGo to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 94.156.185*
The gphysi.dat is providing the Geant3 parameters which were used in the simulation, then IPAIR=0 means there it no pair production,
BUT
you are using geant4 simulation, which does not produce any .dat file. In your case, for reconstruction you use geane for track extrapolation (genfit, pid package), which is a sort of geant3 simulation which has only the electromagnetic part to consider energy loss, no pair production, no decays, no hadronic interaction and so on. This is what you are reading in the .dat file, most probably a Geane constructor is called and the .dat file is created.
Try to do a short geant3 simulation and check if the parameters are changed, they should be. Then, the final answer is: all those zeros are correct.
How they are set? Check gconfig folder. SetCuts.C shows the default parameters for simulation, Geane.C are the parameters for Geane. You can edit them without need of recompilation, but afterwards set them at the original values, if not your sim will be screwed.
 
Read Message
Read Message
Read Message
Previous Topic: NIEL
Goto Forum:
  


Current Time: Sat Aug 08 10:11:45 CEST 2020

Total time taken to generate the page: 0.02739 seconds