GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » Problems with pthread in FairRoot (Problem running cmake in FairRoot CentOS 7)
Problems with pthread in FairRoot [message #22702] Mon, 11 June 2018 10:46 Go to previous message
benny_heiss is currently offline  benny_heiss
Messages: 3
Registered: August 2016
Location: Munich
occasional visitor
From: *natpool.mwn.de
Hi everybody,

after successfully configuring the current version of FairSoft on CentOS 7, I tried to install FairRoot. Running cmake resulted in the following error:

CMake Error at cmake/modules/FindGo.cmake:49 (message):
Go build for go-processor failed!
Call Stack (most recent call first):
examples/advanced/GoTutorial/CMakeLists.txt:6 (build_go_package)


-- Configuring incomplete, errors occurred!

I attached the corresponding CMakeError and CMakeOutput logs. The issue seems to be something related to pthread from what I can gather from the logs. pthread is installed and is also found by cmake:

-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE

Did anyone already encounter this issue? Or is running the current version of FairRoot on CentOS 7 and knows how I can get it up and running?

Thanks for your help!

Cheers,

Benjamin




 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Facing Problem During the Installation of Fairsoft
Next Topic: Problems while installing Fairsoft
Goto Forum:
  


Current Time: Wed Feb 20 06:06:36 CET 2019

Total time taken to generate the page: 0.03445 seconds