GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » Millepede could not be created.
Re: Millepede could not be created. [message #19828 is a reply to message #19804] Mon, 31 October 2016 15:29 Go to previous messageGo to previous message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *gsi.de
Hi,

normally gcc knows where to find the gfortran library because this is a build-in path. In your case the gfortran library is installed at a different location. There are now two differen possibilities to solve the problem. Either you install the proper version of gfortran. Then gcc should find the gfortran library during the linking or you define the proper gfortran location in the link command. I would favor the second option because otherwise you have to recompile with the new fortran compiler.

Could you please execute the following command and report the result.

Quote:

gfortran -print-file-name=libgfortran.so


Ciao

Florian
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: install_cmake.sh script does not recognize installed cmake correctly
Next Topic: FairSoft not compiling due to gfortran problems in mac OS
Goto Forum:
  


Current Time: Mon Oct 18 09:51:18 CEST 2021

Total time taken to generate the page: 0.02067 seconds