GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] PandaRoot rev 27292 fails to compile [PID]
[FIXED] PandaRoot rev 27292 fails to compile [PID] [message #18102] Wed, 01 April 2015 14:43 Go to previous message
Marcel Tiemens is currently offline  Marcel Tiemens
Messages: 47
Registered: January 2014
continuous participant
From: 202.122.36*
I needed to update some files in PandaRoot because I'm basically a developer, but after that it started producing weird errors. So I just ran svn update on the whole of PandaRoot, to make sure that the files are compatible with each other, but this fails to compile, resulting in the following error:

[ 96%] Building CXX object pid/CMakeFiles/Pid.dir/PidCorr/PndPidCorrelator.cxx.o
/home/marcel/pandaroot2/pid/PidCorr/PndPidCorrelator.cxx: In member function 'void PndPidCorrelator::ConstructNeutralCandidate()':
/home/marcel/pandaroot2/pid/PidCorr/PndPidCorrelator.cxx:883:39: error: 'class PndEmcErrorMatrix' has no member named 'GetErrorP7'
TMatrixD covP7=fEmcErrorMatrix->GetErrorP7(*clu);
make[2]: *** [pid/CMakeFiles/Pid.dir/PidCorr/PndPidCorrelator.cxx.o] Error 1
make[1]: *** [pid/CMakeFiles/Pid.dir/all] Error 2

I tried to continue using PandaRoot anyway, but it crashes when I try to run pid_complete.C with the following error:

Error: type PndPidCorrelator not defined

I suppose the two are related, but how can I solve this? I run the external packages version Apr13 and PandaRoot revision 27292 on Ubuntu 14.04.2.


[Updated on: Tue, 21 April 2015 11:46] by Moderator

Report message to a moderator

Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Remove of FairRoot packages from the trunk
Next Topic: [FIXED] Bug of XCode 6.3 harming geant4 compilation
Goto Forum:

Current Time: Thu Jul 25 15:08:08 CEST 2024

Total time taken to generate the page: 0.00547 seconds