GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » Problem with read tree [SOLVED] (Crash when read tree with customized branch)
Problem with read tree [SOLVED] [message #17126] Tue, 29 July 2014 11:52 Go to previous message
Daniel Wielanek is currently offline  Daniel Wielanek
Messages: 14
Registered: October 2012
Location: Warsaw
occasional visitor
From: 194.29.175*
Dear users and developers
I want add new branch to my generator, I used modyfied UrQMD generator and add new branch by:
fTracks  = new TClonesArray("TLorentzVector");

everything during reconstruction goes fine - I get reconstructed tracks and my additional branch, however when I try to read this by some FairRunAna i get this crash:

root.exe': corrupted double-linked list: 0x0000000002c1d1a0 ***

or this:

#10 0x00007f4999f216a8 in TBranch::GetEntry (this=0x3380810, entry=0, getall=0) at /opt/fairsoft/tools/root/tree/tree/src/TBranch.cxx:1242
#11 0x00007f4999f30c20 in TBranchElement::GetEntry (this=0x3380810, entry=0, getall=0) at /opt/fairsoft/tools/root/tree/tree/src/TBranchElement.cxx:2282
#12 0x00007f4999f30b72 in TBranchElement::GetEntry (this=0x337f9e0, entry=0, getall=0) at /opt/fairsoft/tools/root/tree/tree/src/TBranchElement.cxx:2265
#13 0x00007f4999f94d5b in TTree::GetEntry (this=0x32c6b90, entry=0, getall=0) at /opt/fairsoft/tools/root/tree/tree/src/TTree.cxx:4921
#14 0x00007f4999f4ebf2 in TChain::GetEntry (this=0x2eeb2c0, entry=0, getall=0) at /opt/fairsoft/tools/root/tree/tree/src/TChain.cxx:960
#15 0x00007f49937e0ad6 in FairRootManager::ReadEvent (this=0x2eeaeb0, i=0) at /opt/fairsoft/mpdroot/base/FairRootManager.cxx:1105
#16 0x00007f4993800eef in FairRunAna::Run (this=0x2eeabb0, Ev_start=0, Ev_end=5) at /opt/fairsoft/mpdroot/base/FairRunAna.cxx:526

I don't know what is the source of such behaviour. Are there some limitations on FairROOTManager? I tried add dot at the name. When I open this file by using some primitive macro or TBrowser file seems to bee ok, but when I use FaiRunAna - I get those crashes.
In attachement I'm sending my file with data.

Problem was with libraries with reconstruction, I changed version of geomtry and code works!
  • Attachment: evetest2.root
    (Size: 12.77MB, Downloaded 324 times)

[Updated on: Fri, 08 August 2014 12:22]

Report message to a moderator

Read Message
Read Message
Previous Topic: FairPrimaryGenerator
Next Topic: Problem of energy loss of proton in FairROOT
Goto Forum:

Current Time: Sun Jul 14 22:19:51 CEST 2024

Total time taken to generate the page: 0.00764 seconds