GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » NUSTAR » NUSTAR PRESPEC » FRS - TPC Calibrations (Position Calibration Issues)
Re: FRS - TPC Calibrations [message #18304 is a reply to message #18303] Thu, 04 June 2015 10:51 Go to previous messageGo to previous message
thuyuk is currently offline  thuyuk
Messages: 68
Registered: July 2014
continuous participant

From: *ific.uv.es
Hi Liliana,

Quote:
To which data correspond the plots you sent (is it a primary beam and how long after the calibration runs?)?


Those belong to one of the calibration data taken in August 2012, to be more precise, the plots that you are looking at are from:
TPC_cal_s4_mask_0131.lmd


Quote:
If the new_prespec_Go4 plot is for the same data that the prespec code, can you please give them the same binning?


yes, sure, please check them out:
index.php?t=getfile&id=8420&private=0

Quote:
And also, can you please plot separately xc and yc. If you put them in a 2D plot they are plotted all vs all and then we cannot see if one of them is not fine. A plot with the supersposition of all xc and another plot wit all yc can possibly give us a hint.


Could you please be more specific? Did you mean I should plot xc and yc like one of these:
display xc::yc
display xc:::yc

and not
display xc:yc
?

Quote:
So you say that in any case, the calibration that you make in the new_prespec_Go4 does not work for the experimental data inside the same code?


yes, exactly!

Quote:
So it means that the calibration changed at some point. Have you checked when does this happen? Is it a clear difference or the first files are still working with the calibration?


This is my impression, yes... and I cannot tell you when it has been changed, because I see the same issue from the beginning of the experiment.

Quote:
About the prespec code, what do you mean by not being able to replay the mask files?


Well, to be more precise, I can replay them, but I cannot see the mask signal in the corresponding crate and channel where it suppose to be.

Quote:
Do you get an error message?


Yes and no. I tried with many calibration data which the names refer to the ones taken with the mask. Not all of them, but when some of them are replayed, I see the message something like this:
Unexpected geometry (0 instead of expected 9)...


Quote:
Did you check that you have the correct channel for the mask input?


Yes, I checked and confirmed also with the ones that you suggested to Scott in the above threads. In addition, I don't see any other signal in any other channels of the TDCs of the TPCs which I could use and have the same shape as the fiber mask signals have. I could check the lookup table in new_prespec_Go4 where the fiber mask signals should be and then check whether they are there in prespec. This is an accurate way but it is also the long way, because it is somehow hard to follow the algorithms inside the new_prespec_Go4 code. But, I'm positive that I cannot get any fiber mask signal (of TPC S4, the TPC s2 signals are present) in any channel of the TDCs.

Quote:
If you tell me the file name of the calibration mask at S4 I can run it with prespec code to try to understand what happens.


I already wrote it above, but I can put its name here again for convenience:
TPC_cal_s4_mask_0131.lmd


Thanks Liliana!

Tayfun
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: FRS-AGATA-LYCCA dead time
Next Topic: Scattering Angle Cut
Goto Forum:
  


Current Time: Wed Dec 07 07:35:43 CET 2022

Total time taken to generate the page: 0.01232 seconds