GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » EMC » Problems with EMC backward endcap geometry
icon8.gif  Problems with EMC backward endcap geometry [message #17002] Mon, 14 July 2014 15:02 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *to.infn.it
Dear all,
it seems that there are some problems in the geoemtry of the backward endcap, which are hidden with externals apr13 but they appear with new versions of root, and also using dec13 and dec13p1.

In particular, if you run a simulation macro with dec13/dec13p1 with a root backward EC geometry, you have a crash when quitting root, when the TGeoManager is closing the objects. If you run with apr13, everything seems smooth. If you use an EMC geoemtry w/o the roto backward endcap, or with an old .dat geoemtry, the crash is not present.

You can try by yourself, running macro/emc/sim_emc.C where you have to use:

Emc->SetGeometryVersion(11);


(corresponding to file emc_module4_StraightGeo24.4.root).

You will have the following crash:

Toggle Spoiler


In order to check what is going wrong, I have tried to check the macro to create the root file, macro/emc/dedicated/createRootGeoFileBwEnd_Str24.4.C, modifying the path to the media file, I have the following error:

Info in <TGeoManager::CheckGeometry>: Fixing runtime shapes...
Info in <TGeoManager::CheckGeometry>: ...Nothing to fix
Info in <TGeoManager::CloseGeometry>: Counting nodes...
Info in <TGeoManager::Voxelize>: Voxelizing...
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume Emc4
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume QuarterNewVol
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol1
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol2
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol3
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol4
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol5
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol6
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol7
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol8
Error in <TGeoVoxelFinder::SortAll>: Wrong bounding box for volume SubunitVol9
Info in <TGeoManager::CloseGeometry>: Building cache...
Info in <TGeoManager::CountLevels>: max level = 4, max placements = 14
Info in <TGeoManager::CloseGeometry>: 765 nodes/ 20 volume UID's in FAIR geometry
Info in <TGeoManager::CloseGeometry>: ----------------modeler ready----------------
Info in <TGeoManager::Export>: Exporting FAIRGeom FAIR geometry as root file. Optimizations streamed.
Info in <TCanvas::MakeDefCanvas>:  created default TCanvas with name c1
Info in <TGeoManager::SetVisLevel>: Automatic visible depth disabled


This tells me that we have some serious problem, since the same error I get usign apr13 externals.

Could somebody please take a look and fix it? If not, with the new incoming external packages, I will have to comment out the detector from the default reconstruction.

Thanks in advance.

 
Read Message icon8.gif
Read Message
Read Message
Previous Topic: EMC energy and position correction
Next Topic: Cut on minimum track distance for neutrals
Goto Forum:
  


Current Time: Mon Oct 21 01:57:14 CEST 2019

Total time taken to generate the page: 0.02535 seconds