GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] LmdFit does not compile on MAC
Re: LmdFit does not compile on MAC [message #14706 is a reply to message #14705] Mon, 06 May 2013 09:39 Go to previous message
Stefan Pflueger is currently offline  Stefan Pflueger
Messages: 99
Registered: February 2012
continuous participant
From: *superkabel.de
Hi Ralf,

at the moment I'm using things from the tr1, which I believe is not c++11, but is only supported by "newer" compilers (gcc 4.1 or later if I'm not mistaken). I guess since Fairroot already has the dependency of the boost libraries, the best way for the largest compatibility for older compilers/systems would be to use the boost shared_ptrs.
The reason for using c++11 was just that I started to develop my own modeling/fitting framework for arbitrary functions and wanted as few dependencies as possible, hence the shared_ptrs from std.
Ultimately I would like to have this modeling framework to be an external link to the svn (like genfit). I could use a boost version here and then develop a separate version in parallel, but that's kind of work overhead to keep these things synced.

Best regards,

Stefan
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: [FIXED] Error in running in macro runLumi2Reco.C
Next Topic: [INFO] RHO Update done
Goto Forum:
  


Current Time: Tue Jun 18 15:07:38 CEST 2024

Total time taken to generate the page: 0.01122 seconds