GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] Error while compling pandaroot in macbook pro
Re: Error while compling pandaroot in macbook pro [message #14391 is a reply to message #14388] Fri, 25 January 2013 10:22 Go to previous messageGo to previous message
Himani Bhatt is currently offline  Himani Bhatt
Messages: 11
Registered: October 2012
Location: Juelich
occasional visitor
From: *ikp.kfa-juelich.de
Hi Stefano,

Thanks.
Somehow pandaroot is installed in my macbook, but now I am getting some different error while running macro sim_complet.C in that. In Suse system I am able to run these examples but in macbook it is giving following error:

Himanis-MacBook-Pro:run himani$ root -l sim_complete.C 
root [0] 
Processing sim_complete.C...
Warning in <TClassTable::Add>: class PndSdsTask already in TClassTable
Warning in <TClassTable::Add>: class PndSdsMCPoint already in TClassTable
Warning in <TClassTable::Add>: class PndSdsDigi already in TClassTable
Warning in <TClassTable::Add>: class PndSdsStrip already in TClassTable
Warning in <TClassTable::Add>: class PndSdsDetector already in TClassTable
FairRootManager::OpenOutFile("sim_complete.root")
[INFO   ] Media file used : /Users/himani/PANDA/pandaroot/geometry/media_pnd.geo  
Info in (PndGeoHandling::Instance): Making a new instance using the framework.
 -I container name PndEmcGeoPar
<I> PndEvtGenDirect
<I> Particle: pbarpSystem
<I> decfile: /Users/himani/PANDA/pandaroot/macro/run/2pipi.dec
<I> pbar-Momentum: 7.24
<I> Rnd Seed: -1
<I> Rnd Seed changed to 22672
EvtGen:Initializing EvtGen
EvtGen:Storing known decay models
Will register EvtPythia
EvtGen:Main decay file name  :/Users/himani/PANDA/pandaroot/pgenerators/EvtGen/DECAY.DEC
EvtGen:PDT table file name   :/Users/himani/PANDA/pandaroot/pgenerators/EvtGen/evt.pdl
EvtGen:Initializing RadCorr=PHOTOS
EvtGen:No RadCorr engine given in EvtGen::EvtGen constructor, will use default EvtPHOTOS.
EvtGen:In readDecayFile, reading:/Users/himani/PANDA/pandaroot/pgenerators/EvtGen/DECAY.DEC
root.exe(11369) malloc: *** error for object 0x7fff74049860: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Himanis-MacBook-Pro:run himani$ 



I have removed previously installed root and path declared in bashrc as I defined in SuSe system previously.

I also checked gfortran version and it is for 64bit:


Himanis-MacBook-Pro:run himani$ gfortran --version
GNU Fortran (GCC) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.


and gcc version
Himanis-MacBook-Pro:run himani$ gcc --version
i686-apple-darwin11-llvm-gcc-4.2 (GCC) 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.9.00)
Copyright (C) 2007 Free Software Foundation, Inc.



 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: [FIXED] Problems in compiling EvtGenDirect
Next Topic: [FIXED] Not set McMotherIdx
Goto Forum:
  


Current Time: Thu Apr 18 06:40:29 CEST 2024

Total time taken to generate the page: 0.01072 seconds