GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » May11 with ubuntu 11.04
Re: May11 with ubuntu 11.04 [message #11835 is a reply to message #11808] Fri, 20 May 2011 10:53 Go to previous message
M.Babai is currently offline  M.Babai
Messages: 46
Registered: January 2008
Location: Netherlands
continuous participant
From: *KVI.nl
Hi Stefano,

I didn't have these problems compiling original may11 with gcc-4.5.x compilers.

I have faced the same issues before, when tried to compile external packages on mixed mode machines, older semi 64bit. It still happens when installing on virtualized systems (for example xen and 32 on 64 or 64 on 32 bits).
I think the problem comes from the fact that the script tries to find the system type using the kernel information ( uname -m and -s). In this case the output does not correspond with the arch of the installed libs. I solved these things locally just by editting check_system.sh (commenting out exit commands or hard-coding the arch and chip vars) and everything works fine.

Now, I am using root-5.28/00c with may11, changed to this because of problems I had with root-5.29/02.

Kind wishes,
M.

[Updated on: Fri, 20 May 2011 10:55]

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: problems with compiling pandaroot under mac
Next Topic: Reconstruction macro crash
Goto Forum:
  


Current Time: Mon Oct 25 21:56:30 CEST 2021

Total time taken to generate the page: 0.02414 seconds