GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Monte Carlo Engines » Geant4: problem with set seed and cuts
Geant4: problem with set seed and cuts [message #9516] Tue, 06 October 2009 13:52 Go to previous message
Jerome Boucher is currently offline  Jerome Boucher
Messages: 11
Registered: October 2008
Location: IPNO
occasional visitor
From: *zdv.Uni-Mainz.DE
Hi,

I would like to run the same simulation using different seeds. In case of Geant3, the function gRandom->SetSeed(seed) works fine. Concerning Geant4, this function has no effect.

The following method has been also tried. In the file gconfig/g4config.in, a line has been added:
/random/resetEngineFrom full_path/seed.rnd
The file seed.rnd contains the seed value.
If I put 200345, I obtain:

Geant4 has been created.
-I g4Config() using g4conf macro: /vol0/jerome/soft/pandaroot/trunk/gconfig/g4config.in

----- HepJamesRandom engine status -----
Initial seed = 200345
u[] = 0.174685 0.883674 0.958512 0.690013 0.0250537 0.142294 0.783649 0.356081 0.214774 0.69287 0.700302 0.465109 0.22215 0.768752 0.461089 0.397602 0.522215 0.121546 0.960227 0.510892 0.0116568 0.0286447 0.238777 0.585219 0.780612 0.709182 0.082106 0.828601 0.61446 0.0798209 0.688002 0.00978529 0.370831 0.376435 0.710184 0.864017 0.167338 0.21114 0.349235 0.522479 0.943713 0.0702708 0.778742 0.639458 0.506555 0.151751 0.990123 0.564688 0.430497 0.889832 0.995398 0.725368 0.710512 0.0550886 0.0540335 0.0159176 0.728379 0.947141 0.34922 0.20551 0.351029 0.672539 0.118976 0.655784 0.195375 0.0380308 0.293556 0.237497 0.79723 0.158375 0.029761 0.602215 0.616657 0.995638 0.734827 0.943425 0.130007 0.277064 0.306344 0.973337 0.183926 0.547536 0.914344 0.666572 0.210074 0.300351 0.83602 0.267525 0.248549 0.533332 0.1754 0.299529 0.538308 0.555472 0.283894 0.485254 0.222273
c = 0.0216029, cd = 0.456233, cm = 1
i97 = 96, u[i97] = 0.222273
j97 = 32, u[j97] = 0.370831

So the seed seems to be loaded. But, doing two simulations using different seeds, results are identical.


Concerning the cuts, I tried to modify the cut (gconfig/SetCut.C file) from 1 MeV to 100 KeV. But this new value is not taken into account.




Someone has an idea where I'm wrong?



best regards


Jerome



 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: GEANT3: of energy loss and delta rays
Next Topic: elastic neutron scattering in Geant3
Goto Forum:
  


Current Time: Tue Mar 19 00:54:41 CET 2019

Total time taken to generate the page: 0.03582 seconds