GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Bug in GenfitTrack2PndTrack
Re: Bug in GenfitTrack2PndTrack [message #9299 is a reply to message #9296] Thu, 03 September 2009 13:11 Go to previous messageGo to previous message
Lia Lavezzi
Messages: 291
Registered: May 2007
Location: Torino
first-grade participant

From: *pv.infn.it
Hi,
I just uploaded some last changes. The SPU is no more obtained via getSPU, but it is calculated by hand in the first and last point of the track. Previously, using getSPU, the same SPU value was used in the two cases and this was the main reason why the first point was ok, while the second one not.

There is still a problem, however, with the last point: the signs of the momentum components are correct, but there is a very small difference in their value before and after the conversion.

Consider this case as an example:
first hit before conversion:(-0.279309,0.949132,-0.098875)
first hit after conversion: (-0.279309,0.949132,-0.098875)
last hit before conversion:(-0.428044,0.887351,-0.098413)
last hit after conversion: (-0.427660,0.892086,-0.100010)
You can see that for the first hit everything is ok, while for the last the small difference is still there (though the signs are correct).

I am still studying the problem.
Stefano, can you please make your tests on theta and phi with this last change to see if there is an improvement with respect to the last results?
Thanks, ciao,
Lia.
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: MVD covariance matrix = 0.
Next Topic: Vertex fitter for eta_c analysis
Goto Forum:
  


Current Time: Thu Dec 02 20:01:33 CET 2021

Total time taken to generate the page: 0.02509 seconds