GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Error while using runReco.C
Error while using runReco.C [message #8385] Mon, 04 May 2009 08:01 Go to previous message
Sugat V. Shende is currently offline  Sugat V. Shende
Messages: 6
Registered: July 2008
Location: Pune, India
occasional visitor
From: 192.9.200*
Dear All,

I have updated pandaroot via "svn update pandaroot" two days back.
I have also build the directory "build_may09" by using command
> cmake ../pandaroot_may09
> make

It worked.

Then I run the macro ~/pandaroot_may09/macro/runReco.C, I got following error:

root [0] .x runReco.C("etac_to_gg.evt",1000)
- RTDB container factory FairBaseContFact
dlopen error: /home/sugat/panda/build_may09/lib/libPndData.so: undefined symbol: _ZTV12FairTrackPar
Load Error: Failed to load Dynamic link library /home/sugat/panda/build_may09/lib/libPndData.so
(int)(-1)
*** Interpreter error recovered ***

However, macro runMC.C runs fine. Anybody knows the reason behind it and how to solve this error?

with regards
Sugat V. Shende


Department of Physics,
University of Pune,
Pune - 411 007
(India)
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Geometry overlaps!!!!!
Next Topic: config.sh bug
Goto Forum:
  


Current Time: Wed Jul 24 10:41:31 CEST 2024

Total time taken to generate the page: 0.00748 seconds