GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Tracking » still trouble with Geane
Re: still trouble with Geane [message #8257 is a reply to message #8202] Fri, 17 April 2009 10:44 Go to previous messageGo to previous message
Lia Lavezzi
Messages: 291
Registered: May 2007
Location: Torino
first-grade participant

From: *pv.infn.it
Hi Christian,
I talked to Prof. Rotondi about these problems.

First of all, concerning the errors:
1) erpremc/trscsd.F line 148 and
3) erpremc/trsdsc.F line 138
he suggests to try changing the line: RD(J)=S(J)
with: RD(J)=SNGL(S(J))
(and in the same way the RC(J)=S(J))
in order to convert the double precision variable to single precision one. Could you try this and tell us if the error is still there, please?

In addition to this, can you please send me the macro/macros to be able to reproduce these errors? ...in this way we can make tests ourselves.

Prof. Rotondi' s idea is also to modify GEANE in order to be able to handle the tracking error... do I remember correctly that you already modified a bit the FORTRAN code? If so, can you please summarize your changes?

Thank you very much,
Lia.

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Adapter from Genfit to Pnd objects checked in
Next Topic: change in genfit exception handling
Goto Forum:
  


Current Time: Wed Jul 24 16:16:17 CEST 2024

Total time taken to generate the page: 0.00790 seconds