GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » problem with DpmEvtGen library
problem with DpmEvtGen library [message #7649] Fri, 19 December 2008 12:06 Go to previous message
Elisa Fioravanti is currently offline  Elisa Fioravanti
Messages: 84
Registered: January 2008
continuous participant
From: *fe.infn.it
Hello,

I installed the new external packages and the installation works.
But then I'm installing pandaroot and when I do make I have this error message:

macbook-di-elisa-fioravanti:buildPanda elisafioravanti$ make
[ 4%] Built target Base
[ 8%] Built target GeoBase
[ 10%] Built target ParBase
[ 11%] Built target MCStack
[ 12%] Built target Passive
[ 16%] Built target Field
[ 17%] Built target Gen
[ 18%] Built target PGen
[ 19%] Built target DpmEvtGen
Linking CXX executable ../../bin/DPMGen
ld: library not found for -lDpmEvtGen
collect2: ld returned 1 exit status
make[2]: *** [bin/DPMGen] Error 1
make[1]: *** [pgenerators/DpmEvtGen/CMakeFiles/DpmEvtGen_exe.dir/all] Error 2
make: *** [all] Error 2

If I do make in pandaroot/trunk/pgenerators/DpmEvtGen, I have this message:

macbook-di-elisa-fioravanti:DpmEvtGen elisafioravanti$ make
Building lib/libDpmEvtGen.so library ...
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libCore.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libCint.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libRIO.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libNet.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libHist.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libGraf.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libGraf3d.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libGpad.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libTree.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libRint.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libPostscript.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libMatrix.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libPhysics.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libMathCore.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libThread.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libfreetype.a, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libGui.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libEG.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libTreePlayer.so, file is not of required architecture
ld warning: in /Users/elisafioravanti/fairsoft/tools/root/lib/libMinuit.so, file is not of required architecture
ld warning: in tmp/common.o, file is not of required architecture
ld warning: in tmp/decay.o, file is not of required architecture
ld warning: in tmp/dpm_gen.o, file is not of required architecture
ld warning: in tmp/init.o, file is not of required architecture
ld warning: in tmp/rndmget.o, file is not of required architecture
ld warning: in tmp/string.o, file is not of required architecture
Undefined symbols:
"_main", referenced from:
start in crt1.10.5.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [lib/libDpmEvtGen.so] Error 1


I have mac OS X 10.5.6 and gcc version is 4.0.1

Can somebody help me?

Thank you in advance,

Elisa
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Error during PndTpcElectronicsTask
Next Topic: Pandaroot crash due to TParticlePDG.h
Goto Forum:
  


Current Time: Mon Oct 25 22:25:11 CEST 2021

Total time taken to generate the page: 0.02479 seconds