GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » TpcGemTask bug??
TpcGemTask bug?? [message #7267] Thu, 28 August 2008 19:23 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Dear all,
I have found something...strange!

I run macro/lhetrack/run_sim_tpccombi.C"(10,1)". No problem at all. Then run_track_tpccombi.C. No problem.

Now, let's try with DPM.

I run macro/lhetrack/run_sim_tpccombi_dpm.C"(10,4)". No problem at all. Then run_track_tpccombi.C... it seems no problem, but when I type ".q", before exiting I have the following message:

*** glibc detected *** double free or corruption (out): 0x0aa8ad40

From gdb I get the following:

Toggle Spoiler


I have tried also on lxi007.gsi.de machine, exactly the same message (but this time a break).

I have started to comment out all the tasks, and finally I managed to find that the task PndTpcGemTask is giving the problem, or better when I activate it the error appear.

Any chance to know what is going wrong?


 
Read Message
Read Message
Previous Topic: Bug in PndTof
Next Topic: Reading of nonexistent objects
Goto Forum:
  


Current Time: Mon Jul 15 05:05:52 CEST 2024

Total time taken to generate the page: 0.00820 seconds