GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » EmcCluster: Map version 0 does not exist
Re: EmcCluster: Map version 0 does not exist [message #7426 is a reply to message #7425] Fri, 17 October 2008 09:28 Go to previous messageGo to previous message
Aleksandra Biegun is currently offline  Aleksandra Biegun
Messages: 64
Registered: May 2007
Location: Groningen
continuous participant
From: *KVI.nl
Hello Vishwajeet Jha,

try to change map version number from 1 to 2, i.e.

from:
TFile* fsim = new TFile("simfile.root");
TTree *tsim=(TTree *) fsim->Get("cbmsim");
PndEmcMapper *emcMap=PndEmcMapper::Instance(1);
...

to:
TFile* fsim = new TFile("simfile.root");
TTree *tsim=(TTree *) fsim->Get("cbmsim");
PndEmcMapper *emcMap=PndEmcMapper::Instance(2);

Now, we use map version number 2.
You can check which map version you use in the parametrisation file in ./trunk/macro/params/emc.par

Do not edit this file via "jed", use for instance "emacs" or just
loot into in via "more" or "less" programs.

I hope it will work for you.


Regards,
Aleksandra.




Aleksandra Biegun
University of Groningen/KVI
Zernikelaan 25, 9747 AA Groningen
tel. +31 50 363 3630
fax. +31 50 363 4003
 
Read Message icon4.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: simpleEvtGen for fast simulation limited (?)
Next Topic: Fix in lhetrack
Goto Forum:
  


Current Time: Wed Dec 08 14:16:46 CET 2021

Total time taken to generate the page: 0.02235 seconds