GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » EmcCluster: Map version 0 does not exist
Re: EmcCluster: Map version 0 does not exist [message #6919 is a reply to message #6917] Sat, 14 June 2008 18:23 Go to previous messageGo to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *211-62-r.retail.telecomitalia.it
Hi,
in theory this should be just a warning, and the cluster should be given anyhow.

In each case, in order to avoid the problem, you should add your simulation file as friend of your analyzed tree. I.e., if your tree is called "chain", after you create your tree you have to type:

chain->AddFriend("cbmsim","simulationfile.root");
PndEmcMapper *emcMap=PndEmcMapper::Instance(1);


In simulationfile.root there should be the geometry, and then PndEmcMapper should be able to create the proper map.
If this does not work, try to set the branch address of the digi:

TClonesArray* digi_array=new TClonesArray("PndDigiCluster");
chain->SetBranchAddress("EmcDigi",&digi_array);


If this still does not work... I have no idea, ask Dima Smile


 
Read Message icon4.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: simpleEvtGen for fast simulation limited (?)
Next Topic: Fix in lhetrack
Goto Forum:
  


Current Time: Wed Dec 08 13:06:51 CET 2021

Total time taken to generate the page: 0.02357 seconds