GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Monte Carlo Engines » Energy loss in this silicon layer
Energy loss in this silicon layer [message #6574] Tue, 22 April 2008 20:21 Go to previous message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: *physik.uni-giessen.de
Just to follow the discussion about G3/G4 comparison of energy loss, I did some studies.

I have used EmcApd geometry to have one vertical plane of silicon, and I shoot it with a pion/electron gun, theta = 0°, phi 0°->360°, momentum 1GeV.

I have analysed 1000 events for geant3 and geant4, for pions and electrons, using as thickness 2mm, 350um (such as MVD). In particular, for 350um, I have tested two cuts in SetCuts.C: 1MeV (the standard one), and 1keV.

You can find the results in the attached file. The plots show dE/dx (so total energy loss divided by sensor thickness).

You can see that using 2mm as thickness, both G3 and G4 give the same results, even for both pions and electrons.

Using 350um (1MeV standard cut) G3 and G4 give the same peak for pions, but for electrons we have two well separated peaks, as shown in the MVD case. It seems G4 electrons are at the same position of pions.

Using 350um but a smaller cut (1keV), you can see now that G3 and G4 give results which are similar, but not exactly the same. We have a sort of convergence, now electrons and pions have the same energy loss, but in this case G3 gives less energy than G4.

If we compare the plots with 1MeV cut and 1keV cut, we can see that G4 peaks are exactly the same, is the G3 peak who has moved. I am wondering if I reduce further the cuts what could happen (I have tried with 1eV, but it seems our PandaRoot does not digest so well cuts so small).

Comments are welcome.


  • Attachment: dedx_comp.pdf
    (Size: 52.30KB, Downloaded 347 times)
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: First step in VMC
Next Topic: Energy loss in EMC: bug solved
Goto Forum:
  


Current Time: Tue Mar 19 01:19:25 CET 2019

Total time taken to generate the page: 0.02813 seconds