GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Program received signal SIGFPE, Arithmetic exception
Re: Program received signal SIGFPE, Arithmetic exception [message #6137 is a reply to message #6125] Fri, 21 March 2008 00:03 Go to previous messageGo to previous message
Johan Messchendorp is currently offline  Johan Messchendorp
Messages: 693
Registered: April 2007
Location: University of Groningen
first-grade participant

From: *xs4all.nl
Dear all,

I can confirm Arek's message. For the new fairsoft package with Pandaroot rev.2360, I get the following on a Debian etch machine, 32 bit (vmware, gcc 4.1.2, run_sim1.C with TGeant4):

------------------------------------------------------
Index : 23 used in the geometry : Yes recalculation needed : No
Material : DCHmixture
Range cuts : gamma 1 mm e- 1 mm e+ 1 mm
Energy thresholds : gamma 990 eV e- 990 eV e+ 990 eV
Region(s) which use this couple :
DefaultRegionForTheWorld

====================================================================

### Run 0 start.


>>>>>>>>>>>>>>>>>>>>new event
-I CbmPrimaryGenerator: 10 primary tracks from vertex (0, 0, 0)
>>> Event 0
tof volume 14 2212
Hit in fullname /cave_0/tofB01_0/tof02_0/tof07_0/

*** Break *** floating point exception
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
Attaching to program: /proc/9002/exe, process 9002
[Thread debugging using libthread_db enabled]
[New Thread -1223895360 (LWP 9002)]
Failed to read a valid object file image from memory.
0xb7f1d410 in ?? ()
#1 0x00000001 in ?? ()
#2 0x00000000 in ?? ()
Root >
---------------------------------------------------

It works however on a 64 bit configuration (same machine, same gcc compiler). Furthermore, 64-bit MAC OS X 10.5 also works fine....

So, it looks to me like a problem related to 32-bit machines?!?

Johan.



Johan Messchendorp
University of Groningen/KVI
Zernikelaan 25
NL-9747 AA Groningen
The Netherlands
tel. +31-503633558
fax +31-503634003

[Updated on: Fri, 21 March 2008 00:13]

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Problem with G4 Libraries
Next Topic: Problems running Geant under Debian Etch
Goto Forum:
  


Current Time: Thu Dec 01 22:22:36 CET 2022

Total time taken to generate the page: 0.01594 seconds