GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Tracking » Problems with GEANE and trackbase
Re: Problems with GEANE and trackbase [message #6012 is a reply to message #6010] Fri, 07 March 2008 09:35 Go to previous messageGo to previous message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *gsi.de
Hi,

Quote:


Another issue: trackbase uses the magnetic field. It get's this from the CbmRun singleton object. This construct creates nasty dependencies which make it unnecessarily hard to write tests for the code.


first of all you need the field to calculate the coveriants, So if you do not get from the framework where do you get it from! The way how it is done now, enable you to get the same field which was used in simulation.

Quote:


It was always advertized that PandaRoot is getting rid of the cross-dependencies.



This is not a cross dependency, a package in a framework depends on the base of the framework! and not the contrary.

regards

Mohammad


 
Read Message icon9.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Combining Emc reconstruction and Geane
Next Topic: Updated version of CbmGeanePro
Goto Forum:
  


Current Time: Sun Apr 21 11:04:16 CEST 2024

Total time taken to generate the page: 0.01154 seconds