GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Problem with Geane (Error in "runRECO2.C")
Re: Problem with Geane (Error in "runRECO2.C") [message #5729 is a reply to message #5723] Tue, 29 January 2008 16:32 Go to previous messageGo to previous message
Aleksandra Biegun is currently offline  Aleksandra Biegun
Messages: 64
Registered: May 2007
Location: Groningen
continuous participant
From: *KVI.nl
Hi Pablo, hi Ralf,

thank you for the answer.

Pablo, I changed what you suggested, but it is not this case.
When I use debugger (as Ralf suggested) I got info that the problem
is, indeed, in pandaroot/stt/PndSttHelixTrackFitter.cxx program, but connected with this xc = xc - s;
expression (line 1061).

1) parabolic parameters:
a = 0.00266855
b = -0.0616751
c = 0.00060633
digicounter: 15

Program received signal SIGFPE, Arithmetic exception.
[Switching to Thread -1226143552 (LWP 15181)]
0xb2b0f528 in PndSttHelixTrackFitter::Fit4b (this=0x8685428,
pTrack=0x8fe0bf0, pidHypo=2) at
/home/biegun/PANDA/fair/pandaroot/stt/PndSttHelixTrackFitter.cxx:1065
1061 xc = xc - s;


Could you, Pablo, look at it, please?

Thanks!

Greetings,
Ola.



Aleksandra Biegun
University of Groningen/KVI
Zernikelaan 25, 9747 AA Groningen
tel. +31 50 363 3630
fax. +31 50 363 4003
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Problem with G4.9.1 compatibility fix
Next Topic: Missing file in TPC code
Goto Forum:
  


Current Time: Mon Apr 22 08:59:52 CEST 2024

Total time taken to generate the page: 0.01279 seconds