GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Problem with Geane (Error in "runRECO2.C")
Re: Problem with Geane (Error in "runRECO2.C") [message #5727 is a reply to message #5723] Tue, 29 January 2008 15:34 Go to previous messageGo to previous message
Pablo Genova is currently offline  Pablo Genova
Messages: 32
Registered: May 2007
continuous participant
From: *PV.INFN.IT
Dear Alexandra,

it's difficult to say why you see that error, for instance I did not have it on my version!

It looks like an error inside the prefit algorithm: i. e. PndSttHelixTrackFitter class inside pandaroot/stt directory.

Searching for "1) parabolic parameters" ... I suspect
that maybe the following :

if (determ != 0) {
matrixb.Invert();
}

(line 971 of PndSttHelixTrackFitter.cxx) should be changed into

if (determ>0.00001) {bla bla;}

Or other similar errors that on our local version never showed up (division by 0? attempting to retrieve information from an empty pointer?), but it's difficult to find out the error without a code which shows the error itself!!


ciao, Pablo



 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Problem with G4.9.1 compatibility fix
Next Topic: Missing file in TPC code
Goto Forum:
  


Current Time: Mon Apr 22 08:42:08 CEST 2024

Total time taken to generate the page: 0.01149 seconds