GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Tracking » Problem with reconstructed phi values
Problem with reconstructed phi values [message #7859] Mon, 09 February 2009 15:06 Go to previous message
Jerome Boucher is currently offline  Jerome Boucher
Messages: 11
Registered: October 2008
Location: IPNO
occasional visitor
From: *in2p3.fr
Hi,

Since few weeks, I'm working on the channel pbar p -> e+e-pi0. I did some simulations and tried to calculate the missing mass from the 4-vector (pbar + p - e+ - e-). Using the montecarlo values, everything is fine (total momentum, invariantmass, missing mass, etc......). Using the reconstructed values, two bumps, one around -0.5GeV and the second one around 0.5 GeV, appear. But nothing around 0.140 GeV, where one expects the pi0 mass. I checked the total momentum and it seemed correct.

To be sure that I was not doing something wrong, I simulated the
psi(2s) decay like in the pandaroot tutorial in ferrara and I
obtained the same results as in the tutorial.

To simplify the study, I have simulated pbar p -> e+e- (1000 events). Unfortunatly, same problems appear. So, I compared for some events the values of px, py, pz and E written in the output.evt (coming from simpleEvtGen) with the one obtained after reconstruction. We pointed out, with Thierry, that the energy, the total momentum as well as pz are OK but px and py are not OK.

To look more carefully in this, I've simulated 1000 electrons with a 2GeV/c momentum, 20<theta<140, 59<phi<60 for both TPC and STT configuration using respectively run_sim_tpccombi_pgun.C and run_sim_sttcombi_pgun.C. Results are shown in the attached ppt. We can see that for both TPC and STT, montecarlo results are good. Also, px and py histograms of the reconstruction values show that there is a serious problem. Furthemore looking at phi angle (simulated between 59 deg. and 60 deg.), we can see that phi values obtained after reconstruction are far from the expected ones.

Did someone already cross check that the MonteCarlo values agree, within resolution, with the ones coming from reconstruction? Do you see any mistake in my argumentation/demonstration or did I forget something?
attched below is a ppt presentation with the corresponding figures.


Greetings
Jérôme
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: Genfit & MVD
Next Topic: B field scaling for PANDA
Goto Forum:
  


Current Time: Thu Jul 18 15:29:28 CEST 2024

Total time taken to generate the page: 0.00705 seconds