GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » General » GEANE: Propagate to Plane not implemented
Re: GEANE: Propagate to Plane not implemented [message #7415 is a reply to message #7414] Wed, 15 October 2008 11:29 Go to previous messageGo to previous message
Tobias Stockmanns is currently offline  Tobias Stockmanns
Messages: 489
Registered: May 2007
first-grade participant
From: *ikp.kfa-juelich.de
Hi Lia,

you are right. I modified the lines with plo[9] = v0.Dead), plo[10] = v0.Y(), plo[11].v0.Z().

Which is wrong but did not cause any harm, because v0 is orthogonal to v1 and v2.

I corrected it in my code and switched to CbmTrackParP. Now the code runs stable but the results are a puzzling.

I have simulated a 1 GeV proton flying through the MVD. I take Geane to predict the point on the various detector planes from the first point in the MVD. For most of the points the prediction works in the way that the predicted points are close to the MC points from the simulation but some of the points are far outside the detector.

In addition the given errors from Geane are for the x and y coordinate of the points too low and not consistent. For the z coordinate it seems to fit. At least the pull distribution looks reasonable. I have added the two pull distributions to this message. The diagrams are restricted to a range of -10 to 10 otherwise you could not see anything because some pulls get really big.

I hope you have an idea, why this happens.

Cheers

Tobias
 
Read Message icon5.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Materials and radiation lengths in pandaroot
Next Topic: PndFlatParticleGenerator
Goto Forum:
  


Current Time: Mon Jul 15 05:23:06 CEST 2024

Total time taken to generate the page: 0.00935 seconds