GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Error loading libPGen.so
Re: Error loading libPGen.so [message #6705 is a reply to message #6605] Thu, 08 May 2008 17:57 Go to previous messageGo to previous message
Felix Boehmer is currently offline  Felix Boehmer
Messages: 149
Registered: May 2007
Location: Munich
first-grade participant

From: *natpool.mwn.de
Hi,

I just got the same error (clean installation, svn version 2737):

dlopen error: /afs/e18/panda/SIM/fboehmer/cbuild/lib/libPGen.so: undefined symbol: lujets_
Load Error: Failed to load Dynamic link library /afs/e18/panda/SIM/fboehmer/cbuild/lib/libPGen.so


How can I solve this?

EDIT:
I stumbled upon the other thread about this topic after I posted this.

I tried to load libDpmEvtGen before libPGen like Mohammad proposed but the error persists. I also tried a make in the DpmEvtGen directory with no success but I noticed this warning :

Compiling file main.cc ...
main.cc:26: warning: non-local variable ‘<anonymous struct> lujets_’ uses anonymous type


So... does anybody know how to fix this? Any (temporary) solution would be very welcome!


Thanks!

Felix

[Updated on: Thu, 08 May 2008 18:09]

Report message to a moderator

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: include bug in tpc dedx
Next Topic: problem in running reco
Goto Forum:
  


Current Time: Wed Apr 17 01:04:49 CEST 2024

Total time taken to generate the page: 0.01196 seconds