GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Tracking » Problems with GEANE and trackbase
Re: Problems with GEANE and trackbase [message #6294 is a reply to message #6293] Tue, 08 April 2008 14:27 Go to previous messageGo to previous message
Sebastian Neubert is currently offline  Sebastian Neubert
Messages: 282
Registered: March 2006
Location: Munich
first-grade participant

From: *e18.physik.tu-muenchen.de
Hi!

In CbmTrackParP (SD system) I found this inconsistency (at least it is an inconsistency with my understanding):

TVector3 positionsd = util.FromMARSToSDCoord(TVector3(fX, fY, fZ), forigin, fiver, fjver, fkver);
   fU = positionsd.X(); 
   fV = positionsd.Y(); 
   fW = positionsd.Z(); 


The SD system is defined in such a way, that v and w span the detector plane. However this should correspond to x and y when I define a Detectorplane like this:

DetPlane plane(TVector3(0.0,0.0,0.0),TVector3(1.,0.,0.),TVector3(0.,1.,0.));



Looking to the paper by Andrea and Pablo it is clear to me that this is indeed connected to the SP representation where the beam IS a special direction and is assumed to be the x-axis instead of the z-axis as we have in PANDA.

Ideas how to solve this are most welcome!

Cheers!
Sebastian.


Sebastian Neubert
Technische Universität München
Department Physik E18
sneubert@e18.physik.tu-muenchen.de
tel: +49-8928912592

[Updated on: Tue, 08 April 2008 14:32]

Report message to a moderator

 
Read Message icon9.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Combining Emc reconstruction and Geane
Next Topic: Updated version of CbmGeanePro
Goto Forum:
  


Current Time: Thu Jul 18 13:23:48 CEST 2024

Total time taken to generate the page: 0.01013 seconds