GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » General » problem in retriving data from runDemo output
Re: problem in retriving data from runDemo output [message #6127 is a reply to message #6124] Thu, 20 March 2008 11:17 Go to previous messageGo to previous message
Sebastian Neubert is currently offline  Sebastian Neubert
Messages: 282
Registered: March 2006
Location: Munich
first-grade participant

From: *e18.physik.tu-muenchen.de
Hi Dipak!

One problem that I can spot immediately is the following:

GeaneTrackRep obviously requires GEANE. So you cannot use it without setting up geant3. And in addition you always need the complete Framework environment (the runmanager in particular) This takes care of the magnetic field and so on.

This dependency is a bit awkward but it is needed.

For the moment I would suggest, that you put all the things you want to do into another task which you plug to your reco script. Like I have done with TrackStatTask.

Cheers! Sebastian.

PS: I see a bigger context here: persistence of track objects. Let's keep that in mind!


Sebastian Neubert
Technische Universität München
Department Physik E18
sneubert@e18.physik.tu-muenchen.de
tel: +49-8928912592
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Fluka is available now!
Next Topic: Forgotten increment of iterator???
Goto Forum:
  


Current Time: Wed Jul 17 19:56:41 CEST 2024

Total time taken to generate the page: 0.00831 seconds