GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » General » problem in running demo/runMC.C
problem in running demo/runMC.C [message #6090] Mon, 17 March 2008 15:42 Go to previous message
Anonymous Poster From: *gsi.de
Hi all,
I was trying to run recotasks/demo/runMC.C and runDemo.C for my vertex fitter. It was running during KVI workshop and after that also. But last Friday runDemo.C didn't run anymore but runMC.C was running.
Today I tried with the latest version of PANDAROOT (version: 2319), but today even runMC.C didn't run. Could you please let me what is the problem or I have to make some changes somewhere?

Best Regards,
Dipak
------
I got the following errors:
root [1] .x recotasks/demo/runMC.C


============== CbmRunSim: Initialising simulation run ==============
Info in <TGeoManager::TGeoManager>: Geometry CBMGeom, CBM geometry created
-I- CbmGeoMedia Read media
Loading Geant4 granular libraries ...
dlopen error: /misc/cbmsoft/Debian3.1/new/transport/geant4/lib/Linux-g++/libG4detutils .so: undefined symbol: _ZN18G4VPrimitiveScorer8GetIndexEP6G4Step
Load Error: Failed to load Dynamic link library /misc/cbmsoft/Debian3.1/new/transport/geant4/lib/Linux-g++/libG4detutils .so
(int)(-1)
*** Interpreter error recovered ***
Error: Symbol TG4RunConfiguration is not defined in current scope /d/panda02/dipak/pandaroot0308/pandaroot/gconfig/g4Config.C:29:
Error: Symbol TG4RunConfiguration is not defined in current scope /d/panda02/dipak/pandaroot0308/pandaroot/gconfig/g4Config.C:29:
Error: type TG4RunConfiguration not defined FILE:/d/panda02/dipak/pandaroot0308/pandaroot/gconfig/g4Config.C LINE:29
Warning: Automatic variable TG4RunConfiguration* runConfiguration is allocated /d/panda02/dipak/pandaroot0308/pandaroot/gconfig/g4Config.C:29:
Error: Undeclared variable TG4RunConfiguration* runConfiguration /d/panda02/dipak/pandaroot0308/pandaroot/gconfig/g4Config.C:29:
*** Interpreter error recovered ***

*** Break *** segmentation violation
Using host libthread_db library "/lib/libthread_db.so.1".
Attaching to program: /proc/22283/exe, process 22283
Failed to read a valid object file image from memory.
done.
done.
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 22283)]
done.
done.
done.
done.
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: Increase bits for storage dch points in the track
Next Topic: New External packages
Goto Forum:
  


Current Time: Sat Dec 03 23:03:42 CET 2022

Total time taken to generate the page: 0.00963 seconds