GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Charmtask tutorial
Charmtask tutorial [message #5093] Thu, 27 September 2007 12:32 Go to previous message
Klaus Götzen is currently offline  Klaus Götzen
Messages: 293
Registered: June 2006
Location: GSI
first-grade participant
From: *ikf.physik.uni-frankfurt.de
Hi!

I tried to run this Charmtask tutorial (I'm working on lxi008.gsi.de) from the wiki, but I failed to run EvtGen, I get this error when trying 'make bin'

Done making libEvtGenModels.a
gmake[1]: Leaving directory `/d/panda02/kgoetzen/fairroot3/pandaroot/pgenerators/EvtGen/EvtGenModels '
kgoetzen@lxi008:~/work/fairroot3/pandaroot/pgenerators/EvtGen$ make bin
g++ -L. -L/cern/lib/ -L/misc/cbmsoft/Debian3.1/new/cern/clhep/lib -L/misc/cbmsoft/Debian3.1/new/tools/root/lib -o testEvtGen testEvtGen.o -lEvtGen -lEvtGenModels -lEvtGenBase -lCLHEP -l -l -lpacklib -lmathlib -l -lCore -lCint -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -ldl -lg2c -lnsl -lm
/usr/bin/ld: cannot find -l-l
collect2: ld returned 1 exit status

It seems as if there are some variables not set properly... and I really did everything step by step from the tutorial... (I think) For instance macro/run/run_sim.C works, so the pandaroot installations seems to be ok (although EvtGen shouldn't depend on that, right?)

Any ideas?

Thanks,
Klaus


PS: It really seems to be some sort of curse - whatever I try with pandaroot, never ever works sth out-of-the-box ... Sad
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: Problem with cmake
Next Topic: CbmPrimaryGenerator: ReadEvent failed
Goto Forum:
  


Current Time: Tue Dec 07 04:39:44 CET 2021

Total time taken to generate the page: 0.02379 seconds