GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » script does not recognize installed cmake correctly script does not recognize installed cmake correctly [message #20289] Wed, 15 February 2017 10:40 Go to previous message is currently offline
Messages: 2
Registered: February 2017
occasional visitor
From: *
Hello everyone,

I just tried installing the FairSoft external packages onto the HIMster in Mainz using this guide:

On the HIMster, cmake --version outputs the following:

cmake version 3.5.0-rc2

CMake suite maintained and supported by Kitware (

The last line is ignored by the script correctly, but it does not recognize the patch version as 0 but instead fails to parse 0-rc2 completely:

scripts/ line 28: [: 0-rc2: integer expression expected
Found cmake version 3.5.0-rc2 which is older than the
required version 3.3.0 in PATH
This version is to old
install cmake as external package

Consequently, it installs cmake 3.3.2, but that version is too old as well:

CMake Error at CMakeLists.txt:2 (cmake_minimum_required):
  CMake 3.4.3 or higher is required.  You are running version 3.3.2

On HIMster, this is fixable if we correct the patch version parser to

--cmake_installed_patch_version=$(echo $cmake_version_string | cut -d. -f3)
++cmake_installed_patch_version=$(echo $cmake_version_string | cut -d. -f3 | grep -oP '[0-9]{1,3}' | head -1)

Can we add this parser fix to the script, even tough this might be a border case? Also, if the script does install cmake, it should install 3.4.3 or higher, since that is the version that is actually needed.

Thank you!
Read Message
Read Message
Read Message
Previous Topic: libVc.a not found
Next Topic: Millepede could not be created.
Goto Forum:

Current Time: Sun Jul 14 09:03:17 CEST 2024

Total time taken to generate the page: 0.00778 seconds