GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Bug in writing/processing TClonesArray in timebased sim digitisation stage
icon4.gif  Bug in writing/processing TClonesArray in timebased sim digitisation stage [message #19378] Fri, 15 July 2016 14:38
Marcel Tiemens is currently offline  Marcel Tiemens
Messages: 47
Registered: January 2014
continuous participant
From: *kvi-cart.rug.nl
NOTE: I tested this using the EMC only, but it looks like it could be a more general bug.

When trying to see if the timebased simulation at very low rate (200 Hz) would give the same (or at least, very similar) output as the eventbased simulation, I uncovered a bug. It turns out that, for some reason, the first event returns 0 digis (and also 0 waveforms), and is therefore lost, and the last event is written to the tree twice. As a result of the latter, after sorting, the corresponding digis will appear in the output file twice. This leads to the energies of the clusters that are made using those digis being doubled as well.


FYI, apart from this, it looks like the low rate timebased simulation does indeed produce similar results to the eventbased simulation. So, there's some good news there.
 
Read Message icon4.gif
Previous Topic: Problems with macros
Next Topic: genfit2 and electrons - problems with Bremsstrahlung formula
Goto Forum:
  


Current Time: Sun Dec 05 12:39:02 CET 2021

Total time taken to generate the page: 0.02605 seconds