GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » libstdc++.so.6: version `GLIBCXX_3.4.18' not found
libstdc++.so.6: version `GLIBCXX_3.4.18' not found [message #18849] Thu, 07 January 2016 12:46 Go to previous message
Ralf Plag is currently offline  Ralf Plag
Messages: 25
Registered: September 2015
continuous participant
From: *gsi.de
Hi All,

just came back from holidays, no idea what I did before, and stupidly thought the following should work:

rplag@lxg0858:~/build$ . ./config.sh
System during compilation: Debian GNU/Linux 7.9 (wheezy)
x86_64
System now : Debian GNU/Linux 7.9 (wheezy)
x86_64
rplag@lxg0858:~/build$ root -l
/cvmfs/fairroot.gsi.de/gcc_4.8.4/fairsoft/nov15p1_root6/bin/root.exe: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /cvmfs/fairroot.gsi.de/gcc_4.8.4/fairsoft/nov15p1_root6/lib/root/libCore .so.6)

I have the following in my bash_rc:

export SIMPATH=/cvmfs/fairroot.gsi.de/gcc_4.8.4/fairsoft/nov15p1_root6
export FAIRROOTPATH=/cvmfs/fairroot.gsi.de/gcc_4.8.4/fairroot/v-15.11_fairsoft- nov15p1_root6
export LD_LIBRARY_PATH=/cvmfs/it.gsi.de/compiler/gcc/4.8.4/lib64/:$LD_LIBRARY_P ATH
export PATH=/cvmfs/it.gsi.de/compiler/gcc/4.8.4/bin:$PATH
export UCESB_PATH=/u/rplag/ucesb/unpacker

Ideas?

Thanks!
Ralf
 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: FairSoft with GCC in MacOs
Next Topic: External packages and Root 6 cling error
Goto Forum:
  


Current Time: Thu Oct 28 07:32:32 CEST 2021

Total time taken to generate the page: 0.02184 seconds