GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » AGATA » AGATA - AGAPRO » femul emulator (Enable multitrading support of femul)
Re: femul emulator [message #18000 is a reply to message #17997] Thu, 12 March 2015 14:16 Go to previous messageGo to previous message
Angel is currently offline  Angel
Messages: 6
Registered: March 2015
occasional visitor
From: *ikp.physik.tu-darmstadt.de
Hello Olivier,
I just did that on the other system that I am using and it did not enable the multi-tread support.
The system is DELL server, 16 cores INTEL(R) E5620 CPU @ 2.40GHz/12MB cache size and 24GB RAM. It is running Ubuntu server 12.04.3 LTS x86_64 with gcc 4.6.3. When I run the scripts for agapro and femul they give the following:
for agapro ->

[reconfig] conf
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
[AGAPRO] OFT, Internal built-in
[AGAPRO] MGT, Internal built-in
-- Found ADF: /home/dagata/AgataSoftware/lib/libADF.so
[ADF] ADF found.
--> includes in: /home/dagata/AgataSoftware/include,
--> lib: /home/dagata/AgataSoftware/lib/libADF.so,
--> ADF.conf: /home/dagata/AgataSoftware/lib/ADF.conf
[AGAPRO] Narval has not been found on this machine
-- Performing Test CHECK_CXX_FLAG_C11
-- Performing Test CHECK_CXX_FLAG_C11 - Failed
[AGAPRO] Compilation with boost [thread], found on your system, possible ...
[AGAPRO] skstream Found in /usr
[AGAPRO] Compilation with skstream
-- Performing Test CHECK_CXX_FLAG_msse4
-- Performing Test CHECK_CXX_FLAG_msse4 - Success
[AGAPRO] Compilation with msse
---------------------------------
[AGAPRO] + global
-- Found Subversion: /usr/bin/svn (found version "1.6.17")
-- Configuring done
-- Generating done
CMake Warning:
Manually-specified variables were not used by the project:

GUESS_TREAD
---------------------------------

for femul ->

[reconfig] then femul
[reconfig] clean
('[clean] ==> Start cleaning the package ', '--femul')
[clean] in cmakebuild/Release/femul
[clean] DONE
[reconfig] conf
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
[AGAPRO] Narval has not been found on this machine
-- Performing Test CHECK_CXX_FLAG_C11
-- Performing Test CHECK_CXX_FLAG_C11 - Failed
[AGAPRO] Compilation with boost [thread], found on your system, possible ...
[AGAPRO] skstream Found in /usr
[AGAPRO] Compilation with skstream
-- Performing Test CHECK_CXX_FLAG_msse4
-- Performing Test CHECK_CXX_FLAG_msse4 - Success
[AGAPRO] Compilation with msse4
[AGAPRO] SSE FOUND
-- Configuring done
-- Generating done
CMake Warning:
Manually-specified variables were not used by the project:

GUESS_TREAD
---------------------------------

When I run femul ->

######################################
# Using Narval actors without Narval #
######################################

OS is Linux
Not using threads
Not using root
Library ADF is /home/dagata/AgataSoftware/lib/ADF.conf
---------------------------------

The gcc compiler version 4.6.3 supports c11 as an option --std=c++0x. How ever it turns out that this can not be passed as cmake option. Do have any suggestion how to enable it or if not then how to enable boost?

Kindly,
Angel


 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Next Topic: Install
Goto Forum:
  


Current Time: Fri Oct 22 01:22:25 CEST 2021

Total time taken to generate the page: 0.02541 seconds