GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Tracking » Moving to Genfit2
Re: Moving to Genfit2 [message #17877 is a reply to message #17876] Thu, 12 February 2015 11:47 Go to previous messageGo to previous message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Hello Alicia,

I recommend to upload the full development-trunk as it is in /development/genfit2. Several pandaroot packages make use of the genfit(2) classes, and their names and functionalities are changed in genfit2, compared to genfit1-trunks. Therefore, if you upload /genfit2/ alone, in your trunk revision, you would get several level of nasty crashes.

You can do the following:

1) download /development/genfit2/ as it is a new trunk revision
2) try to compile it. If it works smoot (and it should):

3) upgrade your new /hyp/ package to the revision that you like
4) uncomment the line related to the /hyp/ package in the cmake list file. This will produce a crash in pandaroot compilation, because you have still the old genfit functions in your /hyp/ package, I guess.
5) Start to work on that, until it will be solved Smile

I am sorry that I had no time to fix the genfit2 issues for the /hyp/ packages, in th past weeks, while I did it for the other packages.
I very much apprereciate that you are helping, doing yourself.


Please, do not aesithate to ask, if any troubles.

ciao, Elisabeta
 
Read Message
Read Message
Read Message
Read Message
Read Message icon6.gif
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: antiprotons lost above 10 degrees
Next Topic: Backpropagation in Kalman Filter
Goto Forum:
  


Current Time: Thu Jun 13 11:49:25 CEST 2024

Total time taken to generate the page: 0.01146 seconds