GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Analysis » [FIXED] Problems with photon reconstruction in pandaroot
Re: Problems with photon reconstruction in pandaroot [message #15438 is a reply to message #15437] Thu, 05 September 2013 11:43 Go to previous messageGo to previous message
Elisabetta Prencipe (2) is currently offline  Elisabetta Prencipe (2)
Messages: 214
Registered: February 2013
first-grade participant
From: *ikp.kfa-juelich.de
Dear Klaus,

I do not use any mass cut when I ask for truth matched values of the particle, and I guess it is correct like so. Whci code is crashing only because the mass cut around the invariant mass of 2 photons is larger that 20 MeV/c^2? None.
The mass selector which you have seen in my macro is there, at the end of the ftm_block, but it is not used; it is there just because there was much more in that macro, but I gave in the forum the easiest version. It was used just BEFORE and not AFTER teh vertex fit of the various pi0, Ds* was done. Clearly it is not possible in this conditions to apply any fitter. You would not get neither one entry before the memory leak stops your job. You can try yourself.
Even if I apply a mass cut of +/- 20 to the invariant mass of the first 2 photons, it is absolutely non-influent on the memory leak that is created. You can try yourself.

In addition, even if I apply any cut on energy, momentum, whatever in that macro, it is not going over 10 events. Even more: is you try to set up additional cuts in that macro: the memory leak occurs at the event 5 and not 10.

Would we understand that here we got a problem? It is not possible to reconstruct in pandaroot (my personal experience) channels where more than 2 photons are involved. Please, try yourself and you will see.

Pandaroot does not work fine with neutrals.

Thanks for your feedback,
Elisabetta
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: [FIXED] Recontruction of neutrals - macro is very slow
Next Topic: Rho package update - rev 21551 - problem
Goto Forum:
  


Current Time: Tue Apr 23 06:03:44 CEST 2019

Total time taken to generate the page: 0.03917 seconds