GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Analysis » [CLOSED] Wrong particle in FillList
Re: Wrong particle in FillList [message #15049 is a reply to message #15044] Tue, 30 July 2013 15:43 Go to previous messageGo to previous message
Klaus Götzen is currently offline  Klaus Götzen
Messages: 293
Registered: June 2006
Location: GSI
first-grade participant
From: *gsi.de
Hi Lu,


indeed, it looks strange, in particular, that you have charged particles in your gamma list. One issue with your code is, that the keywords are wrong; use 'PionLoosePlus' instead of 'PionLossePlus' etc. Your unknown keyword 'Losse' should lead to default 'All', meaning, that no PID cut is applied.

Maybe you could do an svn update on trunk/rho and trunk/PndTools/AnalysisTools and try again with the correct keywords.

In general, also with correct working PID algorithms, you always might have some wrong particles (from MC truth point of view) in the lists due to misidentification.


Best,
Klaus
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: MVD Particle Identification in analyses
Next Topic: [WONTFIX] Tutorial macro - trunk
Goto Forum:
  


Current Time: Fri Feb 22 17:16:09 CET 2019

Total time taken to generate the page: 0.02836 seconds