GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » FairRunAna::SetGeomFile seems not to work
Still some problems [message #14857 is a reply to message #14844] Mon, 10 June 2013 19:06 Go to previous messageGo to previous message
Volker Friese is currently offline  Volker Friese
Messages: 365
Registered: April 2004
Location: GSI CBM
first-grade participant
From: *gsi.de
Hi Mohammad,

thanks for the quick help! I tried with the fairbase trunk, but still have some problems.

When I now set a geometry file to run_ana, it seems to work (see log_with_geofile), although there is a strange error message in the initialisation of FairBaseParSet:

Quote:

*************************************************************
initialisation for run id 1370260005
*************************************************************
-I- FairRunTimeDB::InitContainer() FairBaseParSet
Error in <TBufferFile::ReadClass>: got wrong class: TGeoManager
Error in <TBufferFile::ReadObject>: got object of wrong class! requested TObjArray but got TGeoManager
Error in <TBufferFile::CheckByteCount>: object of class FairBaseParSet read too few bytes: 69750 instead of 69833
Container FairBaseParSet initialized from ROOT file.


When, however, I try to run without explicitely specifying a geometry file, the program crashes (see log_without_geofile.txt).
 
Read Message
Read Message
Read Message
Read Message
Previous Topic: trouble running event display
Next Topic: FairBaseParSet not initialized
Goto Forum:
  


Current Time: Mon Oct 18 09:37:53 CEST 2021

Total time taken to generate the page: 0.02146 seconds