GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » [FIXED] TGeant4 Error with pbarpSystem
Re: TGeant4 Error with pbarpSystem [message #14689 is a reply to message #14669] Thu, 02 May 2013 15:10 Go to previous messageGo to previous message
Ralf Kliemt is currently offline  Ralf Kliemt
Messages: 507
Registered: May 2007
Location: GSI, Darmstadt
first-grade participant

From: *gsi.de
Hi,

EvtGen has its own description of particles in the EvtGen/evt.pdl file. This mostly matches the root particle description (most probably used in Geant4) defined in fairsoft/etc/pdg_table.txt.
The Psi(2S) for example has the pdgcode and name (30443,"psi(2S)) in EvtGen and (100443,"psi'") in root. Same holds for the psi(3770). The pbarpsystem is even not defined in root.

Geant3 is not so picky about the particle tree, as it tess you the error/warning "can be safely ignored". These particles are not tracked - so why bothering.

To put a particle definition to the TDatabasePDG you may use:
TDatabasePDG::Instance()->AddParticle(...)
Just put it to the macro before FairRun::Run() and your initila system (also pbarp if you like) will be present.

I have the converter from Rho ready in the banks.

However, I think adjusting EvtGen to use the root pdg table would be advisable: one list only.

Cheers.
Ralf
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: [FIXED] crash in run/reco_complete.C
Next Topic: [FIXED] Problem with FTS Mapper PndFtsMapCreator
Goto Forum:
  


Current Time: Mon May 20 11:05:10 CEST 2024

Total time taken to generate the page: 0.01135 seconds