GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » fairbase does not compiile properly as is (10-5-12) [SOLVED]
Re: fairbase does not compile properly as is (10-5-12) [message #14061 is a reply to message #14060] Fri, 05 October 2012 17:02 Go to previous messageGo to previous message
Raphael Cervantes is currently offline  Raphael Cervantes
Messages: 34
Registered: September 2012
Location: Stony Brook University
continuous participant
From: *physics.sunysb.edu
Also, has anyone had any luck using geant4 with the current fairbase?

I tried running the rutherford example,
cd fairbase/examples/rutherford/macros
root run_rutherford.C
And it seemed to run without a hitch.

However, run_rutherford as it is in the repository uses Geant3. I want to use Geant4, so I replace run->SetName("TGeant3"); with run->SetName("TGeant4");
After I try to run_rutherford.C again, I get a segmentation fault. The error is described in geant4SeFault.txt. I naively copied g4libs.C from sep12/transport/geant4_vmc into my sep12-build/share/root/macros and into my gconfig folder in my fairbase. Note: the g4libs.C was not found at all in my sep12 build folder, which might suggest that sep12 is faulty in this aspect. After copying g4libs.C into said folders, I ran rutherford again and obtained the error described in geant4now.txt. I don't know what else to try, so any help is greatly appreciated.

Thank you in advance
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: New update (9/18/2012) not working
Next Topic: Geant4 not working with current fairbase (10/10/12) [SOLVED]
Goto Forum:
  


Current Time: Mon Mar 04 06:34:32 CET 2024

Total time taken to generate the page: 0.01080 seconds