GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » New update (9/18/2012) not working
Re: New update (9/18/2012) not working [message #13992 is a reply to message #13987] Thu, 20 September 2012 16:21 Go to previous messageGo to previous message
Raghav Kunnawalkam is currently offline  Raghav Kunnawalkam
Messages: 63
Registered: February 2012
Location: Stony Brook, New York
continuous participant
From: *
Hi Florian

all my external packages are installed in /Users/raghav/fairsoft/
and they are version 17140.

I also have only one version of root with ROOTSYS = /Users/raghav/fairsoft/tools/root

Also i have attached the config file that i run every time before running fairroot which tells it where all the stuff are.

Here are the actual errors during cmake and make

raghav:~ raghav$ cd fairroot
raghav:fairroot raghav$ source
raghav:fairroot raghav$ cd build/
raghav:build raghav$ cmake ../
--- Found a Mac OS X System 10.7
--- Found GNU compiler collection
--- Build Type: RelWithDebInfo
--- Compiler Flags: -m64
-- Looking for Root...
-- Looking for Root... - Found /Users/raghav/fairsoft/tools/root/bin/root
-- Looking for Root... - version 5.32/00
-- Looking for Pluto...
-- Looking for Pluto... - found /Users/raghav/fairsoft/generators/lib
-- Looking for Pythia6...
-- Looking for Pythia6... - found /Users/raghav/fairsoft/generators/lib
-- Looking for GEANT3...
-- Looking for GEANT3... - found /Users/raghav/fairsoft/transport/geant3/lib/
-- Looking for GEANT4...
-- Looking for GEANT4... - found /Users/raghav/fairsoft/transport/geant4/lib
-- Looking for GEANT4 DATA files...
-- Looking for GEANT4VMC...
-- Looking for GEANT4VMC... - found /Users/raghav/fairsoft/transport/geant4_vmc/lib
-- Looking for VGM...
-- Looking for VGM... - found /Users/raghav/fairsoft/transport/vgm/lib
-- Looking for CLHEP...
-- Looking for CLHEP... - found /Users/raghav/fairsoft/cern/clhep/lib
-- Looking for Java...
-- Looking for Java... - found /usr/bin/java
-- Looking for Perl...
-- Looking for Perl... - found /usr/bin/perl
-- Looking for Rule Checker...
-- Looking for Rule Checker... - No Rules found
-- Looking for Rule Checker... - Not found
-- Looking for Boost ...
-- Boost version: 1.48.0
Build the unit tests.
-- Configuring done
-- Generating done
-- Build files have been written to: /Users/raghav/fairroot/build
raghav:build raghav$ make
[ 1%] Building CXX object fairtools/CMakeFiles/FairTools.dir/FairLogger.cxx.o
In file included from /Users/raghav/fairroot/fairtools/FairLogger.cxx:8:
In file included from /Users/raghav/fairroot/fairtools/FairLogger.h:22:
In file included from /Users/raghav/fairsoft/tools/root/include/Rtypes.h:30:
/Users/raghav/fairsoft/tools/root/include/Rtypeinfo.h:32:10: fatal error: 'typeinfo' file not found
#include <typeinfo>

1 error generated.
make[2]: *** [fairtools/CMakeFiles/FairTools.dir/FairLogger.cxx.o] Error 1
make[1]: *** [fairtools/CMakeFiles/FairTools.dir/all] Error 2
make: *** [all] Error 2
raghav:build raghav$

The first error i have not seen before, and for the second one i am pretty sure that it is because i am not linking the path correctly but i dont know which one i am missing.

Thanks a lot

[Updated on: Thu, 20 September 2012 16:25]

Report message to a moderator

Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Unable to run rutherford example with new update (9/19/12)
Next Topic: fairbase does not compiile properly as is (10-5-12) [SOLVED]
Goto Forum:

Current Time: Mon Jul 15 00:31:03 CEST 2024

Total time taken to generate the page: 0.00786 seconds