GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » General Discussion » My updated fairtools library not loading
Re: My updated fairtools library not loading [message #13658 is a reply to message #13657] Sun, 24 June 2012 07:32 Go to previous messageGo to previous message
Mohammad Al-Turany is currently offline  Mohammad Al-Turany
Messages: 518
Registered: April 2004
Location: GSI, Germany
first-grade participant
From: *dip.t-dialin.net
HI Raghav,

you cannot use FairTools library to add your stuff! even if it has originally only one file, this was done because this file is used everywhere, and the library holding this file has to be loaded before anything else. Adding anything here which depends on any other package of Fairroot will not work!

So why not to create your own library, EICTools or whatever you like? copy the whole stuff you put in fairtools to a "eictools" directory, modify the CMakelist.txt by replacing FairTools with EicTools (also remove the FairLogger from your EicTools directory). In the FairTools directory, either you get it again from the SVN or call "svn revert" there to go back to the original status.

regards,

Mohammad

 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: [SOLVED] about version "1.6.17"-- FairRoot Revision - 15449 Branch
Next Topic: Geant4 not working with mc generation
Goto Forum:
  


Current Time: Thu Feb 22 02:05:44 CET 2024

Total time taken to generate the page: 0.00809 seconds