GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » problem with DpmEvtGen library
Re: problem with DpmEvtGen library [message #11116 is a reply to message #7649] Fri, 22 October 2010 15:07 Go to previous message
manoj.jadhav is currently offline  manoj.jadhav
Messages: 41
Registered: February 2010
Location: Mumbai, India
continuous participant
From: *ikp.kfa-juelich.de
hi dear,

I am compiling my pandaroot trunk on SUSE 11.1 after make it is giving following error

ld: cannot find -lCore
make[2]: *** [lib/libDpmEvtGen.so.0.0.0] Error 1
make[1]: *** [pgenerators/DpmEvtGen/CMakeFiles/DpmEvtGen.dir/all] Error 2
make: *** [all] Error 2

so I just commented out the DpmEvtGen from pandaroot/CMakeLists.txt
then it is giving error

../../lib/libPhotos.so.0.0.0: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[2]: *** [lib/libEvtGen.so.0.0.0] Error 1
make[1]: *** [pgenerators/EvtGen/CMakeFiles/EvtGen.dir/all] Error 2
make: *** [all] Error 2

so I also commented out EvtGen & then it runs fine
But I want to use both DpmEvtGen & EvtGen so what should I do for it ?

I tried by copying above CMakeLists.txt file to DpmEvtGen folder it then it give some other error.



Manoj Jadhav
I.I.T.Bombay
Mumbai
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Error during PndTpcElectronicsTask
Next Topic: Pandaroot crash due to TParticlePDG.h
Goto Forum:
  


Current Time: Tue Dec 07 00:51:27 CET 2021

Total time taken to generate the page: 0.02226 seconds