GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » LVUG » LVUG - Technische Fragen » LabVIEW Anwendung als ActiveX Server
Re: LabVIEW Anwendung als ActiveX Server [message #3048 is a reply to message #3047] Mon, 03 April 2006 20:30 Go to previous messageGo to previous message
Brand is currently offline  Brand
Messages: 180
Registered: January 2004
Location: GSI - SB2 2.256
first-grade participant
From: *dip0.t-ipconnect.de
Hi Heinrich,
Du könntest Dein Problem über Kommandozeilen Parameter lösen.

Wenn Du Deine LabVIEW Applikation lokal startest, gibst Du die Paramter an. Wenn Du die Applikation als AxtiveX-Objekt startest, fehlen diese halt und daran erkennst Du es.

DOS Prompt> ApplicationKind.exe -- /number:2,000000 "/string:local" /boolean:1

Ein Beispiel findest Du mit Hilfe des Example Finders->Index, Suchbegriff: Command; VIs: CommandLine.vi und Description.vi

Über die Eigenschaft Application.Kind findest Du darüber hinaus heraus ob Du das VI in der Entwicklungsumgebung oder als Executable gestartet hast.

Ich habe ein kleines LV8-Projekt und das Blockdiagramm als Bitmap angehängt. Für LV7 musst Du es halt selbst implementieren.

Ich hoffe, dieser Lösungsansatz hilft Dir.

Gruß Holger
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: USB I/O-Kommunikation mit DMM M-3890DT (Fa. Conrad) ?
Next Topic: Treiber für intelligente Nanotec-Schrittmotoren
Goto Forum:
  


Current Time: Tue Aug 04 01:21:29 CEST 2020

Total time taken to generate the page: 0.02729 seconds