GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Scientific Computing » Linux OS » CGI Scripts@GSI
CGI Scripts@GSI [message #2457] Tue, 08 November 2005 14:53 Go to next message
wuestenf is currently offline  wuestenf
Messages: 138
Registered: June 2005
first-grade participant
From: lxg0428.gsi.de
I would like to place a web page containing a small CGI script on the server. How do I call this script from a web page?

If I do:

http://www-hades.gsi.de/~wuestenf/web-bin/talks.pl


I get a 403 error.

Thanks!


Joern Wuestenfeld
Helmholtz - Zentrum Dresden - Rossendorf
01328 Dresden
Re: CGI Scripts@GSI [message #2461 is a reply to message #2457] Wed, 09 November 2005 13:09 Go to previous messageGo to next message
Christopher Huhn is currently offline  Christopher Huhn
Messages: 87
Registered: December 2003
Location: GSI Darmstadt
continuous participant
super-utilisateur

From: lxg0813.gsi.de
Hm,

I get
401 Authentication Required
. This complicates debugging a lot ...
Re: CGI Scripts@GSI [message #2464 is a reply to message #2461] Wed, 09 November 2005 14:43 Go to previous messageGo to next message
wuestenf is currently offline  wuestenf
Messages: 138
Registered: June 2005
first-grade participant
From: lxg0428.gsi.de
So,
I have changed the accesrights. Now you should be able to access the file.


Joern Wuestenfeld
Helmholtz - Zentrum Dresden - Rossendorf
01328 Dresden
Re: CGI Scripts@GSI [message #2466 is a reply to message #2457] Wed, 09 November 2005 15:37 Go to previous messageGo to next message
Christopher Huhn is currently offline  Christopher Huhn
Messages: 87
Registered: December 2003
Location: GSI Darmstadt
continuous participant
super-utilisateur

From: lxg0813.gsi.de
The use of web-bin/ is deprecated. You should be able to run CGIs from your normal web-docs, i. e. http://www.gsi.de/~christo/perldoc.pl
Re: CGI Scripts@GSI [message #2467 is a reply to message #2466] Wed, 09 November 2005 15:55 Go to previous messageGo to next message
wuestenf is currently offline  wuestenf
Messages: 138
Registered: June 2005
first-grade participant
From: lxg0428.gsi.de
I have tried it, and copied the file to web-docs. Still the 403 error. But now it'Äs access forbidden!

Joern Wuestenfeld
Helmholtz - Zentrum Dresden - Rossendorf
01328 Dresden

[Updated on: Wed, 09 November 2005 15:56]

Report message to a moderator

Re: CGI Scripts@GSI [message #2468 is a reply to message #2466] Wed, 09 November 2005 16:05 Go to previous messageGo to next message
Christopher Huhn is currently offline  Christopher Huhn
Messages: 87
Registered: December 2003
Location: GSI Darmstadt
continuous participant
super-utilisateur

From: lxg0813.gsi.de
Looking over the Apache config again CGI exection is possible but has to be explicitely enabled by putting
Options +ExecCGI
into
~/web-docs/.htaccess
. Otherwise the restricted access error will occur.
Re: CGI Scripts@GSI [message #2469 is a reply to message #2468] Wed, 09 November 2005 16:08 Go to previous message
wuestenf is currently offline  wuestenf
Messages: 138
Registered: June 2005
first-grade participant
From: lxg0428.gsi.de
Thanks,

now it works and I was wondering what I changed Grin You must have changed the .htaccesfile in the background at that moment.


Joern Wuestenfeld
Helmholtz - Zentrum Dresden - Rossendorf
01328 Dresden
Previous Topic: Subversion installed
Next Topic: Batch Farm
Goto Forum:
  


Current Time: Wed Oct 27 00:28:13 CEST 2021

Total time taken to generate the page: 0.01907 seconds