GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » R3BRoot » Simulation Issues » Error in running run_sim.C (Fatal in <R3BCave::CloneModule>: Has to be overriden in multi-threading applications.)
Error in running run_sim.C [message #24784] Mon, 06 April 2020 11:55 Go to next message
Maisam.M.Dadkan is currently offline  Maisam.M.Dadkan
Messages: 5
Registered: April 2020
Location: Netherlands
occasional visitor
From: *eduroam.rug.nl
Hi all,

I have recently installed R3BRoot on Ubuntu18.04 on a virtual machine. When I run the test simulation (run_sim.C) I get an error at the end relating to multi-threading. Do you have any idea about this error and how can I fix the problem?
The full log.txt file is attached herewith.

Greets,
Maisam
Re: Error in running run_sim.C [message #24786 is a reply to message #24784] Mon, 06 April 2020 13:53 Go to previous messageGo to next message
Dmytro Kresan is currently offline  Dmytro Kresan
Messages: 166
Registered: June 2004
first-grade participant
From: *unity-media.net
Hi.

Probably, you have installed FairSoft with geant4 in multi-threaded mode. This mode is not yet supported by R3BRoot. Please re-install in single-threaded.

Best regards,
Dima
Re: Error in running run_sim.C [message #24793 is a reply to message #24786] Mon, 06 April 2020 14:04 Go to previous message
Maisam.M.Dadkan is currently offline  Maisam.M.Dadkan
Messages: 5
Registered: April 2020
Location: Netherlands
occasional visitor
From: *eduroam.rug.nl
Thanks a lot Dmytro. Yes, I installed the fairsoft in multi-thread mode. I will reinstall it and check it again.

Greets,
Maisam



M.M.Dadkan
Previous Topic: Problem with FairMCApplication with R3BRoot on dev-branch
Goto Forum:
  


Current Time: Fri Aug 06 04:56:12 CEST 2021

Total time taken to generate the page: 0.01991 seconds