GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » PANDA » PandaRoot » Bugs, Fixes, Releases » Problem installing PandaRoot trunk (rev. 30029) on local work station (installation stops with error messages I don't understand)
Problem installing PandaRoot trunk (rev. 30029) on local work station [message #21003] Wed, 17 May 2017 11:04 Go to next message
Albrecht Gillitzer is currently offline  Albrecht Gillitzer
Messages: 49
Registered: March 2004
continuous participant
From: *ikp.kfa-juelich.de
Hi,

when I wanted to do an "svn update" on my work station, I found that my FairSoft and FairRoot versions were outdated. I then installed the recommended versions. After this I tried to install the current pandaroot trunk version.
I'm getting many messages of the type "cannot open linkdef file xxx.h" which I don't know how serious they are.
The first explicit error message is:
"Error: Symbol delete is not defined in current scope /private/fairsoft/fairsoft_may16p1/pandaroot/stt/PndSttGeometryMap.h:31: "
Then the installation proceeds until:
"[ 42%] Building CXX object pgenerators/EvtGen/EvtGen/CMakeFiles/EvtGen.dir/R01-03-00/src/EvtGenMode ls/EvtWnPi.cpp.o
[ 42%] Linking CXX shared library ../../../lib/libEvtGen.so
[ 42%] Built target EvtGen
[ 42%] Linking CXX shared library ../lib/libPGen.so
[ 42%] Built target PGen
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2"

See the full logfile attached.
What does this mean?

Albrecht
Re: Problem installing PandaRoot trunk (rev. 30029) on local work station [message #21006 is a reply to message #21003] Wed, 17 May 2017 11:15 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 185.97.123*
If you are installing the trunk, are you using root5? If I have understood correctly now the trunk is compatible only with root6.
Re: Problem installing PandaRoot trunk (rev. 30029) on local work station [message #21013 is a reply to message #21006] Wed, 17 May 2017 11:32 Go to previous messageGo to next message
Albrecht Gillitzer is currently offline  Albrecht Gillitzer
Messages: 49
Registered: March 2004
continuous participant
From: *ikp.kfa-juelich.de
Hi Stefano,

Yes, I was assuming that I could still use root5. Is this no longer true? Are you sure??? I was not aware of this.

Albrecht
Re: Problem installing PandaRoot trunk (rev. 30029) on local work station [message #21017 is a reply to message #21013] Wed, 17 May 2017 11:33 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 185.97.123*
Check Ralf message here:

https://forum.gsi.de/index.php?t=tree&th=5422&start=0&#page_ top
Re: Problem installing PandaRoot trunk (rev. 30029) on local work station [message #21018 is a reply to message #21017] Wed, 17 May 2017 11:46 Go to previous messageGo to next message
Albrecht Gillitzer is currently offline  Albrecht Gillitzer
Messages: 49
Registered: March 2004
continuous participant
From: *ikp.kfa-juelich.de
OK, I see!
But what about the statement in the PandaRoot installation guide on the wiki, concerning the installation of the external packages:

"Would you like to install ROOT 6 instead of ROOT 5?
1) Yes
2) No
3) Quit
...
2) ROOT 6 version of PandaRoot is currently not supported."

- ??? -

Albrecht


Re: Problem installing PandaRoot trunk (rev. 30029) on local work station [message #21020 is a reply to message #21018] Wed, 17 May 2017 12:19 Go to previous messageGo to next message
StefanoSpataro is currently offline  StefanoSpataro
Messages: 2736
Registered: June 2005
Location: Torino
first-grade participant

From: 185.97.123*
I wrote that line more than one year ago, most probably it was not updated.
Re: Problem installing PandaRoot trunk (rev. 30029) on local work station [message #21021 is a reply to message #21020] Wed, 17 May 2017 13:02 Go to previous message
Tobias Stockmanns is currently offline  Tobias Stockmanns
Messages: 477
Registered: May 2007
first-grade participant
From: *ext.kfa-juelich.de
I updated it now but it is also written that one should have a look at the "Suggested version of the code".

To clarify the situation here. Any SVN version after the last release has to run with ROOT 6.

Cheers,

Tobias
Previous Topic: [FIXED]Problem when I source /pandaroot/buildpanda/config.sh
Next Topic: Problem installing external packages with Root 6
Goto Forum:
  


Current Time: Wed Aug 05 15:54:44 CEST 2020

Total time taken to generate the page: 0.02567 seconds