GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » Fairroot » External Packages » install_cmake.sh script does not recognize installed cmake correctly
install_cmake.sh script does not recognize installed cmake correctly [message #20289] Wed, 15 February 2017 10:40 Go to next message
roklasen@uni-mainz.de is currently offline  roklasen@uni-mainz.de
Messages: 2
Registered: February 2017
occasional visitor
From: *specf.him.uni-mainz.de
Hello everyone,

I just tried installing the FairSoft external packages onto the HIMster in Mainz using this guide: https://panda-wiki.gsi.de/foswiki/bin/view/Computing/PandaRootInstallGit

On the HIMster, cmake --version outputs the following:

cmake version 3.5.0-rc2

CMake suite maintained and supported by Kitware (kitware.com/cmake).


The last line is ignored by the install_cmake.sh script correctly, but it does not recognize the patch version as 0 but instead fails to parse 0-rc2 completely:

/home/klasen/fairsoft_may16p1/buildFairsoft
scripts/install_cmake.sh: line 28: [: 0-rc2: integer expression expected
Found cmake version 3.5.0-rc2 which is older than the
required version 3.3.0 in PATH
This version is to old
install cmake as external package


Consequently, it installs cmake 3.3.2, but that version is too old as well:

CMake Error at CMakeLists.txt:2 (cmake_minimum_required):
  CMake 3.4.3 or higher is required.  You are running version 3.3.2


On HIMster, this is fixable if we correct the patch version parser to install_cmake.sh:

--cmake_installed_patch_version=$(echo $cmake_version_string | cut -d. -f3)
++cmake_installed_patch_version=$(echo $cmake_version_string | cut -d. -f3 | grep -oP '[0-9]{1,3}' | head -1)


Can we add this parser fix to the install_cmake.sh script, even tough this might be a border case? Also, if the script does install cmake, it should install 3.4.3 or higher, since that is the version that is actually needed.

Thank you!
Re: install_cmake.sh script does not recognize installed cmake correctly [message #20290 is a reply to message #20289] Wed, 15 February 2017 12:12 Go to previous messageGo to next message
Florian Uhlig is currently offline  Florian Uhlig
Messages: 424
Registered: May 2007
first-grade participant
From: *unity-media.net
Hi,

first of all which version of FairSoft do you use?

I am not sure if it makes sense to cover the very special case of RC installations in the general scripts.

The real problem is the usage of a CMake version which is newer than the installed one. Do you know which package introduce the problem?

Ciao

Florian
Re: install_cmake.sh script does not recognize installed cmake correctly [message #20293 is a reply to message #20289] Wed, 15 February 2017 15:25 Go to previous message
roklasen@uni-mainz.de is currently offline  roklasen@uni-mainz.de
Messages: 2
Registered: February 2017
occasional visitor
From: *specf.him.uni-mainz.de
Hi Florian,

I'm trying to install may16p1. I don't know what package caused this error, sorry.
Previous Topic: libVc.a not found
Next Topic: Millepede could not be created.
Goto Forum:
  


Current Time: Sat Oct 23 19:58:33 CEST 2021

Total time taken to generate the page: 0.02171 seconds