GSI Forum
GSI Helmholtzzentrum für Schwerionenforschung

Home » LVUG » LVUG - Technische Fragen » Öffnen von Programm
Öffnen von Programm [message #1454] Tue, 08 March 2005 16:06 Go to next message
Robert Teuber is currently offline  Robert Teuber
Messages: 34
Registered: February 2004
Location: Braunschweig
continuous participant
From: *ibmb.bau.tu-bs.de
Hallo,
habe folgendes Problem: Ich will ein Programm (DDE-Programm) von Labview aus starten um die Verbindung zu einem Messgerät herzustellen. Wenn ich das Programm starte bevor ich die Labviewanwendung starte klappt auch die Kommunikation mit Labview.
Ich habe es mit dem VI "Systembefehl ausführen [System Exec.vi]" versucht. Geht nicht. Es kommt er Fehler: Speicher voll/NI-488: Keine Listerners während des Schreibvorgangs festgestellt"
Dann habe ich versucht Excel von Labview aus zu starten, es kommt die gleiche Fehlermeldung.
Dann habe ich mal das Programm Calc gestartet und auch mal die Bildschirmtastatur. Das ging einwandfrei.
Kann mir jemand weiter helfen? Arbeite mit 7.0
Gruß Robert

[Updated on: Tue, 08 March 2005 16:07]

Report message to a moderator

Re: Öffnen von Programm [message #1455 is a reply to message #1454] Tue, 08 March 2005 16:34 Go to previous messageGo to next message
Manfred Leffler is currently offline  Manfred Leffler
Messages: 28
Registered: November 2004
Location: Norddeutschland
continuous participant
From: 195.243.194*
Hallo Robert,
kann hier Excel mit dem "System Exec.vi" starten.
LV 7.0 unter W2k SP4, Office97
Welches OS und welche Office Version benutzt du?
Welcher Fehler-Code steht im ErrorCluster?
Gruß
Manfred
Re: Öffnen von Programm [message #1456 is a reply to message #1455] Tue, 08 March 2005 17:08 Go to previous messageGo to next message
Robert Teuber is currently offline  Robert Teuber
Messages: 34
Registered: February 2004
Location: Braunschweig
continuous participant
From: *dip.t-dialin.net
Hallo,
danke für die schnelle Antwort. Arbeite mit XP. Der Errorcode ist 2.
Gruß Robert
Re: Öffnen von Programm [message #1458 is a reply to message #1456] Tue, 08 March 2005 19:26 Go to previous messageGo to next message
Robi Biswas is currently offline  Robi Biswas
Messages: 61
Registered: March 2004
Location: Beimerstetten/Ulm - Germa...
continuous participant
From: *dip0.t-ipconnect.de
Hallo Robert,

ich schätze, Du hast ein ganz anderes Problem, z.B. durch Build Array, ungeschlossene Referenzen, übergelaufene I/O Buffer, Windows Problem o.ä. Standalone scheint Dein Problem nicht nachvollziehbar.

Grüsse
Robi
Re: Öffnen von Programm [message #1459 is a reply to message #1454] Wed, 09 March 2005 10:11 Go to previous messageGo to next message
Manfred Leffler is currently offline  Manfred Leffler
Messages: 28
Registered: November 2004
Location: Norddeutschland
continuous participant
From: 195.243.194*
Moin Robert,

habe Hinweis gefunden, der Robi bestätigt.
Error 2 ist eigentlich eine Meldung von Windows.

http://forums.ni.com/ni/board/message?board.id=170&message.id=42788& amp;requireLogin=False
http://forums.ni.com/ni/board/message?board.id=170&message.id=70887& amp;requireLogin=False

"... There is an optional input in the System Exec.vi to set the buffer size."

Suche auch auf NI nach: no listeners write

Viel Erfolg

Manfred
Re: Öffnen von Programm [message #1461 is a reply to message #1454] Wed, 09 March 2005 11:56 Go to previous message
Robert Teuber is currently offline  Robert Teuber
Messages: 34
Registered: February 2004
Location: Braunschweig
continuous participant
From: *ibmb.bau.tu-bs.de
Hallo Leute,
danke für die Antworten. Habe mal ausprobiert was passiert wenn man in die Befehlszeite nicht nur den Prgrammnamen sonder den gesammten Pfad mit Namen eingibt. Dann funtionierts. zum schließen der Anwendung darf in der Befehlszeile dann aber nur der Programmname stehen. Gruß Robert
Previous Topic: LabVIEW RT - Remote Update Service
Next Topic: Kalenderwochenbestimmungsprogramm nach DIN 1355
Goto Forum:
  


Current Time: Tue Jul 23 13:38:02 CEST 2024

Total time taken to generate the page: 0.00756 seconds